Joomla! 3.3 esimene beetaversioon on väljas

Joomla! 3.3

Joomla! 3.3 liini esimene linnuke on kohal! Välja on antud esimene 3.3 beetaversioon.

Beeta versioon on mõeldud kogukonnale testimiseks, enne, kui 22. aprilli paiku antakse välja stabiilne versioon. See võimaldab arendajatel vaadata, kas nende lisaprogrammid töötavad uue versiooni peal laitmatult, näha kujundajatel, kas nende kujundustes on kõik kenasti oma koha peale jäänud ning kõigile teistele annab see võimaluse testida ning vaadata, kas kõik toimib ootuspäraselt. Loomulikult oleks hea kõigist leitud kitsaskohtadest arendajatele teada anda, et vead saaks õigeks ajaks ära parandatud. Rääkides vigadest. Esimeses beetaversioonis on tehtud 290 täiendust/parandust ning oma panuse on andnud 39 inimest. See number ei hõlma ei testijaid ega ka koodi mittekirjutavaid kaastöölisi.

Uuendamine versioonilt 3.2 toimub ühe nupu vajutusega ning mingit suuremat tööd sellega ei kaasne. Ehk siis täpselt nii nagu see Joomla versioonis 3 ikka käinud on. Siinjuures on asjakohene ka meelde tuletada, et antud versioon on beetastaatuses ning sellele sa oma saiti uuendama ei peaks.

See on mõeldud ainult testimiseks ning beetaversioonilt uuemale versioonile uuendada ei saa.

Ajakava

  • 8. aprill – beeta 2
  • 15. aprill – väljalaske kandidaat (RC)
  • 22. aprill - Joomla 3.3 väljastamine

Meeldetuletus versiooni 3.2 turvaväljalasete toe kohta

22. aprilliks 2014 on lisaks Joomla 3.3.0 väljastamisele planeeritud ka versiooni 3.2.4 väljastamine. Sellesse versiooni lisatakse kõik veaparandused, mis on tehtud pärast 3.2.3 välja andmist, mis annab 3.2 kasutajatele pikendatud kasutaja toe perioodiks nii uue koodibaasi, kui vähegi võimalik.

Nagu varasemalt teatatud pikendatakse versiooni 3.2 turvaväljaannete väljastamise aega kuni oktoobrini 2014. See on abiks neile kasutajatele, kelle serverites onmadalam PHP versioon kui 5.3.10. Pikendatud kasutajatoe aja jooksul:

  • 3.2 saab tulevikus turvaparandusi, kui nende järgi on vajadusi
  • 2.5 kasutajatugi jätkub
  • 3.3 kasutajatugi jätkub

Kasutajad, kes ei saa uute PHP versiooninõuete tõttu oma saiti versioonile 3.3 uuendada, saavad ühe-nupuga-uuenduse sooritada pärast seda, kui nende serveris olev PHP on uuendatud versioonile PHP 5.3.10.

Lingid

Laadi alla Joomla 3.3 beeta

blog comments powered by Disqus
Toeta eraser.ee eluspüsimist!