JED lisade uuendamine

Juba alates Joomla! versioonist 1.6 on võimalik Joomlas lisaprogramme automaatselt uuendada. See on olnud suureks abiks, et hoida saite uuendatuna ja seega ka turvalisena. Samas teame praktikast vägagi hästi, et ainüksi selle võimaluse olemasolu ei tähenda veel, et kõik lisade arendajad seda rakendaksid.

Joomla! lisade kataloog toob nüüd aga mängu uue nõudmise, et parandada kõigi Joomla! saitide turvalisust. Turvalisuse esmane eeldus on see, et tarkvara peab olema uuendatud. Seetõttu hakkab alates 10. jaanuarist 2017 kehtima Joomla! lisade kataloogis uus nõue: kõik seal loetletud lisad peavad kasutama Joomla uuenduste süsteemi.

Vastutulekuna neile lisaprogrammidele, mis on juba lisade kataloogis, ei eemaldata neid lisaprogramme kui nad sellele nõudele ei vasta. Selle asemel näidatakse kasutajatele allalaadimise nupu vajutamisel hoiatust, et seda lisaprogrammi ei saa automaatselt uuendada ning, et seda peab tegema käsitsi.

Teade hakkab välja nägema umbes selline.

JED Reminder

Uuenduste süsteemi saavad kasutada nii tasuta lisaprogrammid kui ka tasulised lisaprogrammid. Tasuliste puhul on vaja siis veel kasutada lisaparameetrit, mille abil saab kontrollida, kas kasutajal on õigus uuendusi saada. Kolmanda osapoole uuenduste süsteeme võib jätkuvalt edasi kasutada, aga iva on see, et need lisaprogrammid peavad olema uuendatavad ka läbi Joomla! lisade haldamise süsteemi ning olema võimelised näitama uuenduste olemasolu kasutades Joomlasse sisseehitatud võimalusi.

Lisainfot selle uuenduse kohta võid saada artiklist Joomla! Update System requirement

blog comments powered by Disqus